Hướng dẫn cấu hình telnet, ssh trên Router

Hướng dẫn cấu hình telnet, ssh trên Router

R1 : 192.168.1.1

SW1 : 192.168.1.100

Mục tiêu bài lab thực hiện telnet và ssh từ Switch đến Router

Phần 1 : Telnet

Cấu hình telnet trên Router

Router(config)#interface e0/0

Router(config-if)#ip address 192.168.1.1 255.255.255.0

Router(config-if)#no shutdown

 

Router(config)#line vty 0-> cho phép 1 user kết nối

Line vty 0 1 -> cho phép 2 user kết nối

Router(config-line)#password tientran123

Router(config)#enable password ccna123

 Switch thực hiện telnet đến Router

Đặt IP cho Switch

Switch(config)#interface vlan 1

Switch(config-if)#ip address 192.168.1.100 255.255.255.0

Switch(config-if)#no shutdown

Kiểm tra telnet

telnet 192.168.1.1

 Tại Router kiểm tra

Show users

Gỡ bỏ cấu hình telnet

Router(config)#line vty 0

Router(config-line)#no password

 

Phần 2 : ssh

Cấu hình ssh trên Router

Router(config)#hostname R1

R1(config)#ip domain-name tientran.com

R1(config)#crypto key generate rsa

How many bits in the modulus [512]: 1024

R1(config)#username tien password 123456

R1(config)#line vty 0

R1(config-line)#login local

R1(config-line)#transport input ssh

 

Switch thực hiện ssh đến Router

Switch#ssh -v 2 -l tien 192.168.1.1

Password: 123456

R1>enable

Password: ccna123

R1#show user

R1#show ssh

Tien Tran

Share on Google Plus

0 Blooger-facebook:

Post a Comment